5500 RPM Rattle

tdeperte

Active member
Jun 22, 2023
105
134
Arizona
I've been hearing a rattle noise at about 5500 rpm on my ADV2 Northstar. Turns out it's the drive shaft to the front differential. The dealer pulled the shaft and greased it which helped some. They also observed the shaft was rubbing above the carrier bearing due to some oscillation. They installed a rubber pad in this area and made some adjustments and now the noise is gone.
 
This issue is becoming a major problem. Saw a guy that split his driveshaft in two because of the rubbing on the metal loop
 
The issue is the driveshaft protection loop is rubbing against the driveshaft. If left unchecked it will cut right through the driveshaft.
 
Polaris needs to step up and fix this issue correctly, instead of greasing the joints and gluing a rubber pad on the loop like they did with mine. I still have noise which means it is still rubbing. Neither will last and is not a fix for an oscillating drive shaft.
 
I’d just remove the loop.
I may look for an aftermarket loop that is larger since I have my doubts Polaris will do the right thing. The loop is there for a reason and I wouldn't recommend running without one. If the shaft fails and comes through the plastic tunnel that may be a very bad day.
 
I also have a noise I just noticed with mine, at 5000 rpm and above! Sounds like a rattle, metal on metal can hear it coming from around the shifter area? Can’t really see anything would have to remove skid plate to really see anything! Taking to the dealer today? Don’t want to be left stranded in the middle of no where! Think it’s the drive shaft as well ?
ADV 2 seater
 
I'm the near future I'm going to check on getting the shaft balanced at a local shop. Mine was greased and a rubber pad installed by the dealer and I still have a slight noise. If that's unsuccessful then I'll check into a larger protection loop. It's hard to believe this problem wasn't caught in pre production testing.
 
I also have a noise I just noticed with mine, at 5000 rpm and above! Sounds like a rattle, metal on metal can hear it coming from around the shifter area? Can’t really see anything would have to remove skid plate to really see anything! Taking to the dealer today? Don’t want to be left stranded in the middle of no where! Think it’s the drive shaft as well ?
ADV 2 seater
Remove the front seat, remove the battery box cover and look in under the consol and you can see the Loop, u joint and Zerk fitting and a huge hole used to give access to grease the zerk fitting. This area also gives access to where you can add the adapter to remove the speed limit of 15mph without seatbelt hook up.
 
Anyone have video with sound of this occurring that you can post? My loop has plenty of clearance and shaft zerk greased. I don’t get much of a rattle but more of a buzz sound coming at 5500. It does it in park and drive both for me though so what I am hearing must be different.
 
Picked my ADV2 yesterday 10/22 they also greased the drive shaft said the carrier bearing was good. Noise seems to be gone for the most part. Slight noise but not like before. Did a 60 mile ride no problems! Hopefully no more issues, we’ll still waiting for a wiring harness?
 
Back
Top